Can’t find the ‘libpq-fe.h header ketika memasang gem pg (postgresql)

Sebenarnya ini sih iseng-iseng aja, lagi coba Rails (lagi) mau dipasang di Heroku. Berhubung Heroku ga support MySQL , maka dipasanglah PostgreSQL pada mesin ubuntu saya. Untuk pasang postgresql di ubuntu sih gampang, tinggal pake perintah sudo apt-get install postgresql tunggu aja nanti juga selesai sendiri.

selanjutnya adalah memasang gem untuk postresql, perintahnya juga tinggal pake gem install pg , nah disini ada masalah yang muncul, instalasinya gagal. Teranyata ada peringatan

Can't find the 'libpq-fe.h header
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

untuk mengatasi masalah tersebut, kita harus memasang libpq-dev pada ubuntu kita. Jalankan dengan perintah sudo apt-get install libpq-dev, setelah itu ulangi lagi perintah gem install pg.

Semoga bermanfaat

NB : Ga pake arch, lagi pake ubuntu di vm (vagrant)